Problem with Ogre on Ubuntu 9.10

Get help with installing, running and configuring Orxonox.

Moderator: PPS-Leaders

cmueri
Noxonian Grollknom
Posts: 6
Joined: Mon Sep 28, 2009 2:49 pm

Problem with Ogre on Ubuntu 9.10

Post by cmueri » Fri Nov 20, 2009 7:05 pm

I have some problems with the Ogre version on Ubuntu 9.10. Since the upgrade from Ubuntu 9.04 to 9.10 Orxonox won't start and returns the following error message:

Error: Loading GameState 'graphics' failed: OGRE EXCEPTION(5:ItemIdentityException): Unable to locate vertex program called Ogre/HardwareSkinningOneWeight. in GpuProgramUsage::setProgramName at OgreGpuProgramUsage.cpp (line 61)

So can anyone fix that problem or tell me how to downgrade Ogre and which version is required for Orxonox?

Thx, Christoph

User avatar
greenman
Baron Vladimir Harkonnen
Posts: 360
Joined: Wed Oct 03, 2007 2:53 pm
Contact:

Re: Problem with Ogre on Ubuntu 9.10

Post by greenman » Sat Nov 21, 2009 8:19 am

i think your problem has something to do with shaders... what ogre plugins are being loaded ? (have a look at orxonox.ini and search for ogrePluginsDirectory_ and ogrePlugins_ ; post the contents of ogrePluginsDirectory_)
maybe you could also post your ogre.log file

if you want to downgrade i fear you'll have to build ogre manually, as ubuntu karmic doesn't seem to support ogre-1.4 anymore. have a look at http://www.ogre3d.org/wiki/index.php/Bu ... 2F_Kubuntu . when it comes to download ogre, take 1.4.9 instead of 1.6.x.
There are only 10 types of people in the world: Those who understand binary, and those who don't.

cmueri
Noxonian Grollknom
Posts: 6
Joined: Mon Sep 28, 2009 2:49 pm

Re: Problem with Ogre on Ubuntu 9.10

Post by cmueri » Sat Nov 21, 2009 12:01 pm

Ok. I'm not really used to build and install programs manually, so I try the first option ;)

The content of ogrePluginsDirectory_ (/usr/lib/OGRE) is:
libPlugin_PCZSceneManager.la
Plugin_OctreeSceneManager.la
Plugin_ParticleFX.la
libPlugin_PCZSceneManager.so
Plugin_OctreeSceneManager.so
Plugin_ParticleFX.so
Plugin_BSPSceneManager.la
Plugin_OctreeZone.la
RenderSystem_GL.la
Plugin_BSPSceneManager.so
Plugin_OctreeZone.so
RenderSystem_GL.so

and ogre.log contains:
19:50:02: Creating resource group General
19:50:02: Creating resource group Internal
19:50:02: Creating resource group Autodetect
19:50:02: SceneManagerFactory for type 'DefaultSceneManager' registered.
19:50:02: Registering ResourceManager for type Material
19:50:02: Registering ResourceManager for type Mesh
19:50:02: Registering ResourceManager for type Skeleton
19:50:02: MovableObjectFactory for type 'ParticleSystem' registered.
19:50:02: OverlayElementFactory for type Panel registered.
19:50:02: OverlayElementFactory for type BorderPanel registered.
19:50:02: OverlayElementFactory for type TextArea registered.
19:50:02: Registering ResourceManager for type Font
19:50:02: ArchiveFactory for archive type FileSystem registered.
19:50:02: ArchiveFactory for archive type Zip registered.
19:50:02: FreeImage version: 3.10.0
19:50:02: This program uses FreeImage, a free, open source image library supporting all common bitmap formats. See http://freeimage.sourceforge.net for details
19:50:02: Supported formats: bmp,ico,jpg,jif,jpeg,jpe,jng,koa,iff,lbm,mng,pbm,pbm,pcd,pcx,pgm,pgm,png,ppm,ppm,ras,tga,targa,tif,tiff,wap,wbmp,wbm,psd,cut,xbm,xpm,gif,hdr,g3,sgi,exr,j2k,j2c,jp2
19:50:02: DDS codec registering
19:50:02: Registering ResourceManager for type HighLevelGpuProgram
19:50:02: Registering ResourceManager for type Compositor
19:50:02: MovableObjectFactory for type 'Entity' registered.
19:50:02: MovableObjectFactory for type 'Light' registered.
19:50:02: MovableObjectFactory for type 'BillboardSet' registered.
19:50:02: MovableObjectFactory for type 'ManualObject' registered.
19:50:02: MovableObjectFactory for type 'BillboardChain' registered.
19:50:02: MovableObjectFactory for type 'RibbonTrail' registered.
19:50:02: *-*-* OGRE Initialising
19:50:02: *-*-* Version 1.6.1 (Shoggoth)
19:50:02: Loading library /usr/lib/OGRE/Plugin_ParticleFX
19:50:02: Installing plugin: ParticleFX
19:50:02: Particle Emitter Type 'Point' registered
19:50:02: Particle Emitter Type 'Box' registered
19:50:02: Particle Emitter Type 'Ellipsoid' registered
19:50:02: Particle Emitter Type 'Cylinder' registered
19:50:02: Particle Emitter Type 'Ring' registered
19:50:02: Particle Emitter Type 'HollowEllipsoid' registered
19:50:02: Particle Affector Type 'LinearForce' registered
19:50:02: Particle Affector Type 'ColourFader' registered
19:50:02: Particle Affector Type 'ColourFader2' registered
19:50:02: Particle Affector Type 'ColourImage' registered
19:50:02: Particle Affector Type 'ColourInterpolator' registered
19:50:02: Particle Affector Type 'Scaler' registered
19:50:02: Particle Affector Type 'Rotator' registered
19:50:02: Particle Affector Type 'DirectionRandomiser' registered
19:50:02: Particle Affector Type 'DeflectorPlane' registered
19:50:02: Plugin successfully installed
19:50:02: Loading library /usr/lib/OGRE/RenderSystem_GL
19:50:02: Installing plugin: GL RenderSystem
19:50:02: OpenGL Rendering Subsystem created.
19:50:02: Plugin successfully installed
19:50:02: Creating resource group dataRoot
19:50:02: Added resource location '/home/chris/Studium/Orxonox/menu/data/' of type 'FileSystem' to resource group 'dataRoot'
19:50:02: Added resource location '/home/chris/Studium/Orxonox/menu/data/levels' of type 'FileSystem' to resource group 'General' with recursive option
19:50:02: Added resource location '/home/chris/Studium/Orxonox/menu/data/lua' of type 'FileSystem' to resource group 'General' with recursive option
19:50:02: Added resource location '/home/chris/Studium/Orxonox/menu/data/overlays' of type 'FileSystem' to resource group 'General' with recursive option
19:50:02: Added resource location '/home/chris/Studium/Orxonox/menu/data/particle' of type 'FileSystem' to resource group 'General' with recursive option
19:50:02: Added resource location '/home/chris/Studium/Orxonox/menu/data/tcl' of type 'FileSystem' to resource group 'General' with recursive option
19:50:02: Creating resource group GUI
19:50:02: Added resource location '/home/chris/Studium/Orxonox/menu/data/gui/configs' of type 'FileSystem' to resource group 'GUI' with recursive option
19:50:02: Added resource location '/home/chris/Studium/Orxonox/menu/data/gui/layouts' of type 'FileSystem' to resource group 'GUI' with recursive option
19:50:02: Added resource location '/home/chris/Studium/Orxonox/menu/data/gui/schemes' of type 'FileSystem' to resource group 'GUI' with recursive option
19:50:02: Added resource location '/home/chris/Studium/Orxonox/menu/data/gui/scripts' of type 'FileSystem' to resource group 'GUI' with recursive option
19:50:02: Creating resource group externalDataRoot
19:50:02: Added resource location '/home/chris/Studium/Orxonox/data_extern/' of type 'FileSystem' to resource group 'externalDataRoot'
19:50:02: Added resource location '/home/chris/Studium/Orxonox/data_extern/audio' of type 'FileSystem' to resource group 'General' with recursive option
19:50:02: Added resource location '/home/chris/Studium/Orxonox/data_extern/fonts' of type 'FileSystem' to resource group 'General' with recursive option
19:50:02: Added resource location '/home/chris/Studium/Orxonox/data_extern/materials/programs' of type 'FileSystem' to resource group 'General' with recursive option
19:50:02: Added resource location '/home/chris/Studium/Orxonox/data_extern/materials/scripts' of type 'FileSystem' to resource group 'General' with recursive option
19:50:02: Added resource location '/home/chris/Studium/Orxonox/data_extern/materials/textures' of type 'FileSystem' to resource group 'General' with recursive option
19:50:02: Added resource location '/home/chris/Studium/Orxonox/data_extern/models' of type 'FileSystem' to resource group 'General' with recursive option
19:50:02: Added resource location '/home/chris/Studium/Orxonox/data_extern/gui/fonts' of type 'FileSystem' to resource group 'General' with recursive option
19:50:02: Added resource location '/home/chris/Studium/Orxonox/data_extern/packs/cubemap.zip' of type 'Zip' to resource group 'General' with recursive option
19:50:02: Added resource location '/home/chris/Studium/Orxonox/data_extern/packs/skybox.zip' of type 'Zip' to resource group 'General' with recursive option
19:50:02: Added resource location '/home/chris/Studium/Orxonox/data_extern/gui/fonts' of type 'FileSystem' to resource group 'GUI' with recursive option
19:50:02: Added resource location '/home/chris/Studium/Orxonox/data_extern/gui/imagesets' of type 'FileSystem' to resource group 'GUI' with recursive option
19:50:02: Added resource location '/home/chris/Studium/Orxonox/data_extern/gui/looknfeel' of type 'FileSystem' to resource group 'GUI' with recursive option

User avatar
greenman
Baron Vladimir Harkonnen
Posts: 360
Joined: Wed Oct 03, 2007 2:53 pm
Contact:

Re: Problem with Ogre on Ubuntu 9.10

Post by greenman » Sat Nov 21, 2009 3:36 pm

hm... seems like if i try to start without direct rendering ...

what does glxinfo | grep direct say ?
does it work if you start it with sudo ./run ?
There are only 10 types of people in the world: Those who understand binary, and those who don't.

cmueri
Noxonian Grollknom
Posts: 6
Joined: Mon Sep 28, 2009 2:49 pm

Re: Problem with Ogre on Ubuntu 9.10

Post by cmueri » Sat Nov 21, 2009 4:25 pm

Direct rendering says 'yes', but also sudo ./run returns the same error message.

User avatar
1337
Baron Vladimir Harkonnen
Posts: 521
Joined: Wed Oct 10, 2007 7:59 am

Re: Problem with Ogre on Ubuntu 9.10

Post by 1337 » Sun Nov 22, 2009 1:57 pm

The error message you get is actually different from the original one (AmbientOneTexture) because I manually removed AmbientOneTexture in your data_external folder (don't forget to restore once it works again).

As I mentioned, we've got the same problem on tardis afaik (tried it at the beginning of this semester).
I also compared the original media folders of Ogre v1.4 and v1.6 with diffutils and couldn't find any indication that we forgot some migration work with vertex whatever.
Google result also didn't bring up useful results so far but I'll try again today.

Unfortunately I've really got no idea why this happens. Especially since it works on some boxes but not others..
http://www.xkcd.com/
A webcomic of romance, sarcasm, math, and language.

solex
Noxonian Grollknom
Posts: 8
Joined: Sun Mar 07, 2010 4:27 pm

Re: Problem with Ogre on Ubuntu 9.10

Post by solex » Sun Mar 14, 2010 2:58 am

I run Ubuntu 9.10 on a Lenovo Thinkpad X200, running into the same problem when launching the game. It's also present on a Lenovo Ideapad in combination with Kubuntu, as far as I heard. Both Notebooks are half year old. Since the same problem emerges on Tardis systems, I wouldn't assume that support for new hardware poses a problem. I didn't try it with a different distribution though. Hopefully Ubuntu 10.04 solves that.

User avatar
greenman
Baron Vladimir Harkonnen
Posts: 360
Joined: Wed Oct 03, 2007 2:53 pm
Contact:

Re: Problem with Ogre on Ubuntu 9.10

Post by greenman » Sun Mar 14, 2010 9:58 am

this problem should actually already be solved (since last monday late afternoon).
you might have to update data_extern though ?!
There are only 10 types of people in the world: Those who understand binary, and those who don't.

solex
Noxonian Grollknom
Posts: 8
Joined: Sun Mar 07, 2010 4:27 pm

Re: Problem with Ogre on Ubuntu 9.10

Post by solex » Sun Mar 14, 2010 9:04 pm

Nope, still pretty much the same problem...
Did update both code and data_extern and recompiled.
svn co https://svn.orxonox.net/game/data/trunk data_extern

A data_extern/materials/textures/cross.tga
A data_extern/materials/textures/asterix.tga
A data_extern/materials/textures/sphere.tga
A data_extern/materials/scripts/Sphere2.material
A data_extern/materials/scripts/Asterix.material
A data_extern/materials/scripts/Cross.material
Checked out revision 6520.
Attachments
orxonox_ubuntu.9.10.jpg
orxonox_ubuntu.9.10.jpg (74.44 KiB) Viewed 10778 times

User avatar
1337
Baron Vladimir Harkonnen
Posts: 521
Joined: Wed Oct 10, 2007 7:59 am

Re: Problem with Ogre on Ubuntu 9.10

Post by 1337 » Sun Mar 14, 2010 9:08 pm

This really is rather peculiar. Unfortunately I cannot even begin to imagine how this could possibly happen. I mean, we never deliberately display that background while playing.
http://www.xkcd.com/
A webcomic of romance, sarcasm, math, and language.

User avatar
greenman
Baron Vladimir Harkonnen
Posts: 360
Joined: Wed Oct 03, 2007 2:53 pm
Contact:

Re: Problem with Ogre on Ubuntu 9.10

Post by greenman » Sun Mar 14, 2010 11:00 pm

this doesn't seem to be the same problem as described above

it the problem that only (if at all) 2d objects get rendered and no 3d objects
the problem on tardis was a different one, wasn't it?!
solex' could be related to driver issues of new intel integrated graphics cards ...

there is a change that 10.04 fixes this ...
There are only 10 types of people in the world: Those who understand binary, and those who don't.

solex
Noxonian Grollknom
Posts: 8
Joined: Sun Mar 07, 2010 4:27 pm

Re: Problem with Ogre on Ubuntu 9.10

Post by solex » Mon Mar 15, 2010 9:12 am

greenman wrote:this problem should actually already be solved (since last monday late afternoon).
you might have to update data_extern though ?!
Ah, right. The ogre exception concerning the AmbientOneTexture hasn't shown up anymore since the update. Didn't notice it, because I manually deleted the materials file.

Btw, I also got those once:
*** Identifier: Create class-hierarchy
orxonox # bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)

bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
But after doing " sudo apt-get purge bluez-alsa " it didn't show up anymore either.

User avatar
greenman
Baron Vladimir Harkonnen
Posts: 360
Joined: Wed Oct 03, 2007 2:53 pm
Contact:

Re: Problem with Ogre on Ubuntu 9.10

Post by greenman » Mon Mar 15, 2010 9:20 am

hm... the reason for this could be that we do not select the audio out device manually at the moment (we did once, but there have been problems concerning this)
in your case it might have selected the bluetooth-alsa device and found no connected device which supports this...
There are only 10 types of people in the world: Those who understand binary, and those who don't.

solex
Noxonian Grollknom
Posts: 8
Joined: Sun Mar 07, 2010 4:27 pm

Re: Problem with Ogre on Ubuntu 9.10

Post by solex » Tue May 04, 2010 8:07 am

Upgrading to Ubuntu 10.04 actually solved the problem!

User avatar
greenman
Baron Vladimir Harkonnen
Posts: 360
Joined: Wed Oct 03, 2007 2:53 pm
Contact:

Re: Problem with Ogre on Ubuntu 9.10

Post by greenman » Tue May 04, 2010 8:19 am

cool, probably this is/was an issue with pulseaudio and openal
There are only 10 types of people in the world: Those who understand binary, and those who don't.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest