Page 1 of 2

SIGABRT at startup (missing material?)

Posted: Sat May 31, 2008 6:52 pm
by Nowic
I can't run orxonox on any of my systems. It crashes at startup on my Ubuntu 8.04 and Debian Lenny (Testing) machine. Trunk rev 1492, Data rev 1763
Do I need a special revision of the data repo?

Code: Select all

Texture: bar2a.tga: Loading 1 faces(PF_A8R8G8B8,800x80x1) with 5 hardware generated mipmaps from Image. Internal format is PF_A8R8G8B8,1024x128x1.
terminate called after throwing an instance of 'Ogre::ItemIdentityException'
  what():  OGRE EXCEPTION(5:ItemIdentityException): Could not find material Orxonox/NavMarker in OverlayElement::setMaterialName at OgreOverlayElement.cpp (line 330)
Trying to restore XAutoKeyRepeat
recieved signal SIGABRT
try to write backtrace to file orxonox.log
Unregistering ResourceManager for type BspLevel
*-*-* OGRE Shutdown

Code: Select all

= time: Sat May 31 20:45:21 2008
Program received signal SIGABRT, Aborted.
[Switching to Thread 0xb6fd66c0 (LWP 28928)]
0xb7f7a410 in __kernel_vsyscall ()
#0  0xb7f7a410 in __kernel_vsyscall ()
#1  0xb7410085 in raise () from /lib/tls/i686/cmov/
#2  0xb7411b55 in abort () from /lib/tls/i686/cmov/
#3  0xb7634480 in __gnu_cxx::__verbose_terminate_handler ()
   from /usr/include/boost/../../lib/
#4  0xb7631d05 in ?? () from /usr/include/boost/../../lib/
#5  0xb7631d42 in std::terminate ()
   from /usr/include/boost/../../lib/
#6  0xb7631e6a in __cxa_throw ()
   from /usr/include/boost/../../lib/
#7  0xb7d59a3c in Ogre::OverlayElement::setMaterialName ()
   from /usr/include/boost/../../lib/
#8  0xb7d6e574 in Ogre::PanelOverlayElement::setMaterialName ()
   from /usr/include/boost/../../lib/
#9  0x080ea470 in orxonox::RadarOverlayElement::init (this=0x85ff328, 
    leftRel=0.5, topRel=0.899999976, dimRel=0.200000003, container=0x858d7d0)
    at /home/simon/scratch/orxonox/trunk/src/orxonox/hud/
#10 0x080e607b in HUD (this=0x84c7a78, zoom=1)
    at /home/simon/scratch/orxonox/trunk/src/orxonox/hud/
#11 0x080d679a in orxonox::Orxonox::loadPlayground (this=0x8166f20)
    at /home/simon/scratch/orxonox/trunk/src/orxonox/
#12 0x080d6b71 in orxonox::Orxonox::start (this=0x8166f20)
    at /home/simon/scratch/orxonox/trunk/src/orxonox/
#13 0x080d533d in main (argc=1, argv=0xbfbc2054)
    at /home/simon/scratch/orxonox/trunk/src/orxonox/
Kill the program being debugged? (y or n) [answered Y; input not from terminal]

Posted: Sat May 31, 2008 7:58 pm
by x3n
did you checked out the media repository from ?
if you checked it out to another directory than "Media", you must set the following entry in bin/orxonox.ini to the right path:

Code: Select all

And you should use the network branch, - old branches or the trunk might only run with older versions of media (~revision 1700)

Posted: Sat May 31, 2008 10:26 pm
by Nowic
Yes I did. And it seems to load a lot of stuff before it crashes.

Now I checked out revision 1700 of the data repository, but like that it just misses an other material.


Please document the dependencies of the trunk :-/

Posted: Sun Jun 01, 2008 2:01 pm
by x3n
I can't reproduce this error. But you should really use the network branch, because our trunk is outdated. The presentation used the network branch too. Or you wait some hours, we're right about to merge network back to trunk. After merging, orxonox will work with the latest revision of Media. Sorry for the trouble. Same procedure as every semester. ;)

Posted: Sun Jun 01, 2008 6:50 pm
by Nowic
Ok, I'll wait until the trunk is up to date.

Posted: Mon Jun 02, 2008 12:16 pm
by x3n
Trunk should work now.

Posted: Wed Jun 04, 2008 3:12 pm
by Nowic
Nice, it works now.

But two problems remain:

1. cmake complains that boost is missing, but it compiles. I have version 1.34.1 and I cleared the cache twice.

Code: Select all

simon@simonpc:~/Projekte/orxonox/trunk$ cmake .
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Check size of void*
-- Check size of void* - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- checking for one of the modules 'OGRE;/usr/pack/ogre-1.4.5-sd/i686-debian-linux3.1/lib/pkgconfig/OGRE.pc'
--   found OGRE, version 1.4.6
--   libraries : OgreMain from /usr/lib
--   includes  : /usr/include/OGRE
-- Found enet: /usr/lib/
-- Found BoostLibrary: thread
-- Found BoostLibrary: filesystem
-- Boost was not found. Set the Boost_INCLUDE_DIR cmake cache entry to the directory containing the boost include files. E.g /usr/local/include/boost-1_33_1 or c:\boost\include\boost-1_33_1
-- OpenAL was found.
-- FreeAlut was found
-- Ogg was found.
-- Vorbis was found.
-- Found ZLIB: /usr/lib/
-- Found Lua: /usr/lib/
-- Configuring done
-- Generating done
-- Build files have been written to: /home/simon/Projekte/orxonox/trunk
2. No input devices are working (no mouse, no keyboard). Do I have to bind them manually?

Posted: Thu Jun 05, 2008 12:30 am
by x3n
I think problem 1 was solved today.
Problem 2 is known but not yet fixed, try to copy the content of def_keybindings.ini into keybindings.ini.

Posted: Thu Jun 05, 2008 6:27 pm
by 1337
Error number one with finding boost has been fixed in the current trunk.

However I'm starting to feel bad about the second one. Does it occur too, when you delete keybindings.ini and start the game then? It should then load the configValues from def_keybindings.ini and store them into keybindings.ini
But that obviously doesn't seem to work.

It's likely a problem with the configValues or with the KeyBinder, but I couldn't image where, since it actually has nothing to do with the binding, but rather with an empty file....

Posted: Fri Jun 06, 2008 12:56 pm
by Nowic
Yes deleting keybindings.ini solves it! I even have 10fps with the free drivers. Yeah! Should there be any sounds or music?

Posted: Fri Jun 06, 2008 2:35 pm
by x3n
Yes, there should be music, but there isn't :D
Our soundengine is still in development, there are some problems on several systems, except tardis and beni's notebook. ;)

Posted: Fri Jun 06, 2008 4:35 pm
by beni
Even there it's not perfect!!

See this post for the sound bug and for fixes. Right now we (I) work on a new audio object for the even easier use of the audio.

Posted: Fri Jun 06, 2008 6:14 pm
by 1337
But where the heck does the empty keybindings.ini come from? I don't believe in ghosts..., so there must be a piece of code that creates such a file when orxonox is started the first time...
But I can't imagine where and it doesn't occur on my box at all.

Posted: Wed Jun 11, 2008 9:16 am
by Nowic
@1337: Can you recommend a cheap exorcist so I can get rid of my ghosts? ;)

To solve the data trunk mismatch, I think it would be a good idea to use svn 'tags'. With tags, users could always check out data/tag/trunk and orxonox/trunk and it should work. (as long as you keep the tag updated)

Tagging would also ensure that old versions can be accessed easily. e.g. /data/tag/0.1.0 and /orxonox/tag/0.1.0. And nobody needs to memorize revision numbers.

Posted: Wed Jun 11, 2008 9:39 am
by 1337
Hmm, good coders are definitely not cheap ;)

But I totally agree with the tags. We could also name them with for instance "hud", "trunk", "core3", like the branches in the other repo.

Right now we don't even have branches for the media repository, so we really have to change something there.
I can do something as long as I'm allowed to do so, because that repo is definitely not within my kingdom... :D